Start by reading :

As always :

yum --enablerepo=remi update firefox

No xulrunner update, this RPM provides his bundled Gecko engine.

Most of extensions are now compatibles and works as expected.

About Java plugin, version provided by OpenJDK is not compatible (OJI support dropped), so you must switch (back) to the Sun Java and use the new extension (NPAPI). Quick notes (need to be changed according to version and architecture used):

rpm -e java-1.6.0-openjdk-plugin
rpm -ivh jre-6u17-linux-amd64.rpm
ln -s /usr/java/jre1.6.0_17/lib/amd64/ /usr/lib64/mozilla/plugins/

RPM are available for Fedora ≥ 8.